What's new

Solved Is My Surface 2 Faulty

GreyFox7

Super Moderator
Staff member
I launched Splashtop and used the browser, launched apps, watched a YouTube video ... between SP3 and Surface 2 no problems. perhaps you could be more specific with what exactly is slow...
 

kundas1

Well-Known Member
I also used splashtop religiously with no problems or lags, the only problem I was having with splashtop was the 1080p wasn't clear, and this was because of splashtop and not my S2... it would always seem blurry. But streaming and playing things was great!
 

GreyFox7

Super Moderator
Staff member
Please try another remote control app.
What is the resolution on your laptop and the other laptop?
 

oion

Well-Known Member
My Splashtop app performs fine with the client installed on my Win7Pro desktop (v2.1.0.1 and v2.6.2.4A respectively). Text is clear (but tiny). Well enough that I can dink around in an MMO.

Make sure you didn't accidentally touch the smooth/sharp button on the bottom Splashtop app menu bar, which pops up when you swipe from the bottom or right-click. (Edit: Oh, that's in response to someone else who mentioned blurriness.)
 
OP
P

Paul Roberts

New Member
@GreyFox7 - The Microsoft remote desktop app seems fine. Resolution of both computers is 1920x1080.
@oion I just can't understand it :) Tried every setting there is but yeah tried smooth and sharp, no difference at all.
 

kundas1

Well-Known Member
yea that is VERY laggy, try another remote app like greyfox7 said... and if you find those other ones are laggy then something is def. wrong with your network
 

GreyFox7

Super Moderator
Staff member
yea that is VERY laggy, try another remote app like greyfox7 said... and if you find those other ones are laggy then something is def. wrong with your network
Well since remote desktop worked ok it's something with the app, the way it grabs the screen, or makes the connection. He should probably contact The SS :) (Spalshtop Support)
 
OP
P

Paul Roberts

New Member
Yep, have an active ticket with those guys too :) Thanks for the help and advice guys, I'm completely out of ideas....
Hope their support guys can help me out. Seems odd it's the same on 2 Surface 2's though, leading me to believe my network / computer config is at fault... but why does it work fine perfect on the Android phone? Brain hurts!!
 

GreyFox7

Super Moderator
Staff member
Yep, have an active ticket with those guys too :) Thanks for the help and advice guys, I'm completely out of ideas....
Hope their support guys can help me out. Seems odd it's the same on 2 Surface 2's though, leading me to believe my network / computer config is at fault... but why does it work fine perfect on the Android phone? Brain hurts!!
Ok but if Remote Desktop works fine then your network is ok. this in a Splashtop specific issue.
Connect up with Remote Desktop and play a video OR do one of the worst things you can do on a Remote Connection... open a large PDF and scroll down. That's a horrendous task for Remoting.
 

Members online

Top