What's new

Screen going haywire on excel and other graphs

Winbat

New Member
Hi there,

The screen on my Surface Pro 6 has recently started playing up but only when displaying certain websites or programs.

It seems to happen most commonly with Excel and with websites that happen to show graphs.

I'm attaching a screenshot and a video to show what's happening!

Any idea on how to fix or what's going wrong would be appreciated!
 

Attachments

  • weird screen.png
    weird screen.png
    345.3 KB · Views: 138
  • weird-screen-vid.zip
    904.8 KB · Views: 108

sharpuser

Administrator
Staff member
Very strange. Of course, video driver, or accelerator is suspect. Have you tried rolling back your display driver?
 
OP
W

Winbat

New Member
I thought it was an unusual problem! I have rolled back the display driver to no avail! Any other ideas/suggestions?
 

sharpuser

Administrator
Staff member
A few things come to mind:

1. Make sure all ports are clean of debris. A culprit could be metallic shavings or threads attracted to the magnetic connector of the Surface Port. The display on my SP3 had a similar screen glitch as you are showing until I found some metal shavings. I think I should not have placed the SP3 down on the carpet as I was doing. Attracted debris.

2. Moisture damage. This includes condensation from rapid temperature change. This usually goes away, though, as your computer warms up.

3. Graphic firmware.

4. Possible remedy by a Windows Reset, "Keep my files" option.

5. Possible remedy by a Windows restore, "Remove everything" option.

Let us know ...
 

Turbo4AWD

Active Member
Any luck yet? I personally have received several updates to my Surface Pro 6. Firmware updates, Display driver updates, Win10 20H2 updates, etc. Maybe one of those will help fix the issue? It sounds like a Driver issue, but it could be any of what SharpUser mentioned. I hope you find a solution.
 

Members online

Top