What's new

SP7 - No audio after upgrade to Windows 11

OP
M

massimo

New Member
the package has an entire stack of driver and it has not a setup.exe
if i try to install them manually the OS give issues on the audio driver says it has no certificate

these are the warning i get on my SP7

thanks

massimo
 

Attachments

  • Immagine 2021-11-18 201731.png
    Immagine 2021-11-18 201731.png
    95.6 KB · Views: 225
  • Immagine 2021-11-18 201918.png
    Immagine 2021-11-18 201918.png
    112.7 KB · Views: 226

sharpuser

Administrator
Staff member
I know you’ve probably tried EXACTLY this before, but if not …

- Disable and REMOVE drivers for all sound hardware. Then cold reboot.
 
OP
M

massimo

New Member
oh, thanks a lot!
it worked
the SP7 reinstalled Realtek audio driver instead of the Intel one and now audio works again

much thanks!

massimo
 

shuttlenote

New Member
Apologies for bumping an old thread. I'm having same issues as OP.

Followed sharpuser's suggestion and the sound will work for a minute or so after the reboot. Then reverts back to the Intel drivers and no sound again. I disabled the Audio Controller, hit Uninstall and checked off "Attempt to remove driver from device", and finally rebooted.

Is there anything I'm missing here?

Thanks in advance!
 

Attachments

  • Screenshot 2022-01-03 124733.png
    Screenshot 2022-01-03 124733.png
    5 KB · Views: 151
Last edited:

sharpuser

Administrator
Staff member
Sorry you are having that trouble, @shuttlenote. What seems to be happening is that Windows thinks the Intel driver is newer, and is a suitable replacement.

Have you tried directly downloading new Realtek drivers? I believe the latest version is R2.82 (2017-07-26).
 
Top