What's new

SP2 won't charge or power on (weird circumstance, please read)

Rawry

New Member
For backstory, i let my girlfriend use my SP2 while I was at work... So all I have to go on is what she has told me.
She went to plug in the charger, and didn't know her butt from her elbow... lol. So she said she touched the magnetic charger to the dock connectors mistakenly thinking it was the charging port, which made something flicker and then boom. Dead.
Did she somehow fry it? I've tried a brand new charger with it and absolutely nothing. It doesn't even light the charger up. : ( It seems like a bizarre thing if that is truly what killed it. I'll probably take it in somewhere but figured it wouldn't hurt to ask..
 

sharpuser

Administrator
Staff member
Yes, sounds like the some very low voltage connection got a dose of higher voltage and current. Doesn't sound good. Design flaw? Sorry about this. I have doubts a repair shop could figure out what components to replace, or be able to do the job.
 
OP
R

Rawry

New Member
Yes, sounds like the some very low voltage connection got a dose of higher voltage and current. Doesn't sound good. Design flaw? Sorry about this. I have doubts a repair shop could figure out what components to replace, or be able to do the job.
That’s what I was afraid of… I asked a local guy via email so I’ll see what he says in case he somehow is familiar with these but you’re probably right on the money.
Trying a SP3 right now and yeesh the downgrade to ntrig hits harder than I thought it would.
 

Staff online

Members online

Top