What's new

Just got Surface Pro 4, says "Preparing Automatic Repair"

PhilipCases

New Member
Just got it today. I went through the setup process. Then I restarted it. Then it showed the Surface logo with "Preparing Automatic Repair" at the bottom. The it said "Diagnosing your PC" then it goes into the never ending loop of Automatic Repair. WTF!? I am pissed right now. I can't use it at all. PLEASE HELP!
 

erik braun

New Member
Had same problem, really stinks! Somewhere in the loop I was able to choose restore from cloud or so. I did that and after long wait everything was restored again and now running fine.
 
OP
P

PhilipCases

New Member
Had same problem, really stinks! Somewhere in the loop I was able to choose restore from cloud or so. I did that and after long wait everything was restored again and now running fine.
I tried doing that but a dialog box titled "sysreset.exe - Application Error" appears then the only option is "Click on OK to terminate the program". HOW DO I FIX THIS? :(((((
 
OP
P

PhilipCases

New Member
UPDATE: Problem just got way worse. After attempting USB Recovery, I tried the Restore from cloud method and this time it didn't crash. It stayed on 0% the whole time so I canceled it and restarted the SP4. Now when I turn it on, all I get is the Surface logo flickering on the screen rapidly a few times then it enters the Surface UEFI screen. FML! WHY??? PLEASE HELP ME! :(
 

Nuspieds

Active Member
UPDATE: Problem just got way worse. After attempting USB Recovery, I tried the Restore from cloud method and this time it didn't crash. It stayed on 0% the whole time so I canceled it and restarted the SP4. Now when I turn it on, all I get is the Surface logo flickering on the screen rapidly a few times then it enters the Surface UEFI screen. FML! WHY??? PLEASE HELP ME! :(
There's certainly not anything wrong with posting questions here, but keep in mind that your machine is under warranty.

So, never hesitate to contact Microsoft where you will be able to connect with a live tech support agent, rather than having to wait for forum posts. The bottom line is that you paid good money for a device, it is under warranty, so call them and get the live support you paid for and deserve. ;)
 

robertcan

Member
I returned my first SP4 after similar issues and many hours online with MS Support. If I had it to do over again, I would've returned it after the first day of issues instead of suffering through 3 days of agony.

Bottom line, if it's not working out of the box, EXCHANGE IT for one that works. You'll be much happier once you get one in your hands that works :)
 

raqball

Active Member
I had a similar problem but mine was stuck where it said something like "PC rebooted during install please restart to continue update" Pressing the OK button rebooted to the same screen. Over and over and over.

I downloaded Win 10 to USB stick and booted to it. This let me get into the HD settings where I formatted the primary drive. After that a reboot brought me to where I could recover from cloud. I did that and everything is working fine now.

Not sure what caused my issue but it was a pain in the rump. I know I could have just exchanged it but I got one with minimal light bleed and wanted to keep it at all costs.
 

Members online

Top