What's new

Brand new SPX crashed after W10 Update

herzi

New Member
Hi all, i received my brand new SPX yesterday. SQ2 / 16 GB / 512GB.
it´s completly fresh. i use a surface dock (i already had from my Pro4) and everything was great. 2 external Monitors, external Speaker, external webcam, keyboard and mouse, .... work fine from the beginning.
SPX now wants to update some drivers and even a W10 systemupdate.
downloading, installing ,.... as usual
after the required newstart of the system, the black screen with the logo is frozen and nothing happens.

no reaction on powerbutton, also when pressing 15/30 sec.. or in combination with the volum+ button.

Has anyone an idea if there is a poddibility to get my SPX run again??

THANKS A LOT!!!!
Christian
 
OP
H

herzi

New Member
The MS Support told me that there is a general problem with updates on SPX. They will change my device. Hopefully the new one works with updates.
 
OP
H

herzi

New Member
The new device will arive today. Has anyone experiences with W10 updates on SPX? I am not sure how long i can you it without updating the OS.
 

jnjroach

Administrator
Staff member
I have two SP X devices and neither has had this issue, sounds like a fluke. I have one on Windows 10 and one on Windows 11 currently.
 
OP
H

herzi

New Member
Many thanks for your response. I got the new one today but have not installed any updates yet. But then I will try and hope it works. I actually wanted to go to W11 too. Did you have any problems until now? Many thanks!!!!
 

GreyFox7

Super Moderator
Staff member
I just had a Blue Screen

DPC_WATCHDOG_VIOLATION​

on my original ProX for the first time ever. I saw a post about the latest update causing a problem but didn't pay any attention to it.

I'd assume this will get fixed with another update.
 

jnjroach

Administrator
Staff member
Many thanks for your response. I got the new one today but have not installed any updates yet. But then I will try and hope it works. I actually wanted to go to W11 too. Did you have any problems until now? Many thanks!!!!

I'm running Windows 11 without any major issues, I'm also running the new ARM64 Office Insider Build.


I just had a Blue Screen

DPC_WATCHDOG_VIOLATION​

on my original ProX for the first time ever. I saw a post about the latest update causing a problem but didn't pay any attention to it.

I'd assume this will get fixed with another update.

IIRC - the latest Firmware updates should have fixed that specific bug-check.
 

Members online

No members online now.
Top