What's new

Surface Detach: Hardware Failure

Dan0219

New Member
For a Surface Book 2 - Has anyone else see this message at the bottom right corner of the screen? I have the message, but the screen detaches and reattaches just fine. When I click the icon, it tells me "General Failure". I've checked the troubleshooting, but nothing applies. I check for updates every week so I know I'm not behind on any. So, does anyone have any ideas for what ails my Book? Thank you in advance.
 
OP
D

Dan0219

New Member
Wow. A couple hundred views on this and no ideas. Is there a moderator available to provide any insight?
 

sharpuser

Administrator
Staff member
I have two Surface Book 2 units. I had experienced this error for a few weeks (about two years ago), which turned out to be a small sliver of vinyl which got caught up in the connector. A bright light revealed the problem, including a tiny bit of adhesive left over from the debris. The vinyl was from the protective skin I had attached some time before.

Just like the links posted above, clean any debris in your connectors, including the blade side. Also note that the magnetic feature around the connectors tends to attract slivers of metal which could get caught up in those connectors.
 

sharpuser

Administrator
Staff member
Another thing to check: Your SDXC drive may be giving you trouble. It is reconnected whenever the clipboard (screen) is attached to the keyboard (base). Perhaps if you have media plugged in there, remove and re-insert.
 
OP
D

Dan0219

New Member
Thank you to everyone that offered help. Unfortunately, it did not work. Scrubbed the connections twice. No luck. Same error message.
 
OP
D

Dan0219

New Member
Yep. I just don't understand what the heck is going on. I also removed the SDXC, restarted, put it back. Message never left the screen. It's obviously still working, but just really annoying.

Also, my camera now won't work for facial recognition. I presume there is a set of drivers available for all of this - should I just reinstall?

Thank you for following up.
 

Av8tr

New Member
I have two Surface Book 2 units. I had experienced this error for a few weeks (about two years ago), which turned out to be a small sliver of vinyl which got caught up in the connector. A bright light revealed the problem, including a tiny bit of adhesive left over from the debris. The vinyl was from the protective skin I had attached some time before.

Just like the links posted above, clean any debris in your connectors, including the blade side. Also note that the magnetic feature around the connectors tends to attract slivers of metal which could get caught up in those connectors.
Sharpuser,

I have had the same issue, "Surface Detach: Hardware Failure" icon in the bottom right of screen. It appeared after completing an update. I have followed lists and lists and more lists of instructions in an attempt to "fix" the problem to no avail. The icon is still there, but doesn't seem to negatively affect operations of the Surface Book 2. Have you come up with any solid fix for this issue?
 

sharpuser

Administrator
Staff member
My fix was to clean the port and blade connectors. That includes blowing air across the ports. If you are using any protective skin or decals, make sure there is no interference with the tight fit along the hinge.
 

Members online

Top