What's new

Solved Problem with Dock and external monitor

GeoffJ

New Member
I have been successfully using a Surface Pro 3 in a dock with two monitors, one via an HDMI adaptor in the mini display port in the dock, the other via a VGA adaptor in the on board mini display port in the Surface Pro 3. It’s been running Windows 10 and going like a dream.

Suddenly the monitor used via the dock (HDMI) has stopped displaying.

After taking the following diagnostic steps I believe the problem is somewhere in the Surface Pro 3 software config because I think I have eliminated everything else.
I have :

- Swapped over the monitor connections by plugging the HDMI adaptor into the on board mini port, and the VGA adaptor into the dock port. This made the HDMI monitor work and not the VGA. Therefore both monitors and adaptors are working properly.

- Took the dock back to JB HiFi and swapped it (they were great, bought 8 months ago). The new dock didn’t change anything and behaved exactly like the old dock. Therefore I believe the dock is okay

So this leaves me with the Surface Pro 3. The hardware seems to be working okay so I suspect it’s something in the software configuration. When I go into the Display Settings, it just won’t detect the monitor connected through the dock.

Continuing to troubleshoot, I disconnected all cables from the dock then reconnected the power to the dock, inserted the SP3, and then connected a monitor to the dock. No good.

I would like to reload the firmware or drivers for the dock, but don’t know what it is in the device list.

Does anyone have any ideas on what to do next?
 

knackers1111

New Member
Try two button restart, holding volume up button while pressing power button for ~10 seconds. This worked to fix an undetected type cover, locked landscape orientation and undetected monitor via dock, which all occurred at the same time recently with me.
 
OP
G

GeoffJ

New Member
Thanks knackers1111.
With the surface in the dock and both monitors plugged in, I unplugged everything else, and did what you suggested, and it resolved my problem.
Thank you very much.
I was unsure about what to do with all the options that came up, but just ignored them and everything worked.
So grateful.
I'm sure I'd done that before, but maybe not.
Cheers.
 

Members online

Top